Page 1 of 1

Windows DDE Broken?

Posted: Sat Apr 14, 2007 9:16 am
by yfisaqt
I don't know if it's my computer or not, but trying to double click on a ".cfdg" file using the Windows explorer returns a Windows error message "Windows cannot find '<file>'. Make sure you typed the name correctly, and then try again. To search for a file, click the Start button, and then click Search." I modified the extension file handling to not use DDE, but rather to open the file directly, and it worked, but each time the program starts, it resets the extension file handling to use DDE, and I can't open the files again by using Windows explorer.

Any one have an idea how to make this work?

Posted: Sat Apr 14, 2007 1:49 pm
by MtnViewJohn
Ugh. This kind of thing is hard to debug. I will look at the DDE registration code to see if it is wrong. Have you installed a previous version of Context Free?

Posted: Sat Apr 14, 2007 9:49 pm
by yfisaqt
This is my first time using Context Free. I'm running version Should I uninstall and reinstall?

Posted: Mon Apr 16, 2007 9:08 pm
by MtnViewJohn
Uninstall and then install version 2.1 (the beta). I think I fixed the DDE in 2.1 (crosses fingers).

Posted: Mon Apr 16, 2007 10:23 pm
by yfisaqt
I installed the 2.1 beta, and I couldn't get Context Free to launch. I saw a note about VC++ redistributables (and even though I have a VC++ development machine), for kicks and grins I installed the VC++ redist executable, and tried again. It still didn't launch. I tried copying the VC++ dll's into the application folder, still didn't work. I took the VC++ runtimes from the 2.0 stable setup and dropped those in the folder, and it still didn't work. Every time I launched, it said "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem." I gave it hearty try, and couldn't get it to launch. (I even tried launching dependency walker, and didn't find more insight).

Posted: Tue Apr 17, 2007 6:22 pm
by yfisaqt
Okay, I got it working, and yes DDE is working. I extracted the manifest resource from the executable and found the VC++ runtime version being requested was higher than what I had installed. I found I didn't have SP1 installed for my VC++ dev environment. After I applied SP1 Context Free launched successfully. Thanks for your help!

Posted: Tue Apr 17, 2007 8:07 pm
by MtnViewJohn
That's appalling. I can't believe that you couldn't run Context Free after running vcredist_x86 just because you were down-rev on VC++. Microsoft sucks.

Posted: Mon Dec 01, 2008 3:12 am
by yanchuchi
Under Windows 3.1 and 9x it is possible to crash the system by badly programmed DDE, because the message queue can be filled. NT does not crash in this way, COM does not suffer from the problem at all.