Getting started issues with Linux Mint 64bit

If you're having trouble using Context Free or don't understand the language, ask for help here.

Moderators: chris, MtnViewMark, MtnViewJohn

Post Reply
phraxos
Posts: 1
Joined: Wed May 28, 2014 6:06 pm

Getting started issues with Linux Mint 64bit

Post by phraxos » Thu May 29, 2014 12:07 pm

INTRO: Hi, I cant wait to get started with CFA but am having trouble with the basics. I am 3rd year Comp. Sci. student so am shocked I am having issues and yet no one else seems to have had these issues in the forums. Me not smart as I thought. Anyways...Hopefully someone can help me with a response that will assist any future noobiles.

SUMMARY OF EFFORTS SO FAR: I downloaded ContextFree 3.0.7 compressed zip file (v23) (10.3MB) and extracted it. Tried compiling it (on seperate attempts) with "make" and "make clean" and "make install". Then per the Readme while in the top level of the CF3 directory I ran "./cfdg -s 500 input/mtree.cfdg mtree.png". This results in error "bash: ./cfdg: No such file or directory".

QUESTIONS:
1. So where is this cfdg file? I could not find it anywhere in the file tree (except the source files in src-common).

2. Are earlier versions such as 2.2.2 still available?

3. What am I obviously not grasping about this whole thing or what document have I obviously not read or comprehended?

Thank you for your time.
I promise to make the donation if I get this working!

User avatar
MtnViewJohn
Site Admin
Posts: 844
Joined: Fri May 06, 2005 2:26 pm
Location: Mountain View, California
Contact:

Re: Getting started issues with Linux Mint 64bit

Post by MtnViewJohn » Thu May 29, 2014 10:50 pm

I just created a Linux Mint 16 VM and compiled Context Free. I had to install the g++, bison, flex, and libpng12-dev packages. There is no 'make install' target, I should fix that. The Makefile just creates cfdg at the top of the source tree.

nik282000
Posts: 6
Joined: Sun Nov 10, 2013 8:35 pm

Re: Getting started issues with Linux Mint 64bit

Post by nik282000 » Wed Dec 05, 2018 10:43 pm

Reviving a dead thread but I just wanted to mention that I got the latest version 3.1(v31) to compile under Debian 9 (Stretch) with relatively few issues.

Like John said above, I had to install the following packages, g++, bison and flex. libpng12-dev is not available under stretch but libpng-dev seems to cover the requirement, I also had to install libicu-dev because I was getting "unicode/ucnv.h: No such file or directory" from src-unix/posixSystem.cpp.

After that I ran make and then ran the test script and it all seemed to work.

Thanks, John!

User avatar
MtnViewJohn
Site Admin
Posts: 844
Joined: Fri May 06, 2005 2:26 pm
Location: Mountain View, California
Contact:

Re: Getting started issues with Linux Mint 64bit

Post by MtnViewJohn » Fri Dec 07, 2018 9:31 am

I'm curious why you were looking for libpng12-dev. I thought the dependencies list had libpng-dev (which is currently libpng 1.6.x).

-- john

nik282000
Posts: 6
Joined: Sun Nov 10, 2013 8:35 pm

Re: Getting started issues with Linux Mint 64bit

Post by nik282000 » Fri Dec 07, 2018 4:29 pm

In your previous post you had mentioned libpng-12 but (now) I also see that it was a couple years ago. My mistake.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests