Picture showing in Gallery but not Gallery 2

If you're having trouble using Context Free or don't understand the language, ask for help here.

Moderators: mtnviewmark, MtnViewJohn, chris

Post Reply

flembobs
Posts: 32
Joined: Tue Oct 09, 2012 3:00 pm

Re: Picture showing in Gallery but not Gallery 2

Post by flembobs » Fri Sep 27, 2019 4:05 am

I think the pic is just all out broken now and I can't delete it.

User avatar
MtnViewJohn
Site Admin
Posts: 857
Joined: Fri May 06, 2005 2:26 pm
Location: Mountain View, California
Contact:

Re: Picture showing in Gallery but not Gallery 2

Post by MtnViewJohn » Fri Sep 27, 2019 11:45 am

I was reconfiguring the server yesterday. It may have been in a strange state during your upload.

flembobs
Posts: 32
Joined: Tue Oct 09, 2012 3:00 pm

Re: Picture showing in Gallery but not Gallery 2

Post by flembobs » Fri Sep 27, 2019 1:18 pm

I tried deleting it and reposting - there's a broken image in my user gallery.

flembobs
Posts: 32
Joined: Tue Oct 09, 2012 3:00 pm

Re: Picture showing in Gallery but not Gallery 2

Post by flembobs » Sat Sep 28, 2019 4:22 am

I've tried re-uploading a few times now. I'm not able to upload the image to the gallery at all.

User avatar
MtnViewJohn
Site Admin
Posts: 857
Joined: Fri May 06, 2005 2:26 pm
Location: Mountain View, California
Contact:

Re: Picture showing in Gallery but not Gallery 2

Post by MtnViewJohn » Sat Sep 28, 2019 2:59 pm

This is very strange. I can see your designs Solar and Sun in the database. When I query the gallery backend it returns both of them. Neither show up on the gallery main page and only Sun shows up on the gallery newest designs page. If you check the Creative Commons checkbox then they both show up. Something weird is happening in the front-end code.

flembobs
Posts: 32
Joined: Tue Oct 09, 2012 3:00 pm

Re: Picture showing in Gallery but not Gallery 2

Post by flembobs » Sun Sep 29, 2019 3:20 am

Thanks for looking into it! I hope it's nothing too serious.

Let me know when it's safe to re-upload.

flembobs
Posts: 32
Joined: Tue Oct 09, 2012 3:00 pm

Re: Picture showing in Gallery but not Gallery 2

Post by flembobs » Sun Oct 13, 2019 1:10 pm

Gallery is still messed up for me btw.

I can't seem to like or comment on people's posts reliably.

User avatar
MtnViewJohn
Site Admin
Posts: 857
Joined: Fri May 06, 2005 2:26 pm
Location: Mountain View, California
Contact:

Re: Picture showing in Gallery but not Gallery 2

Post by MtnViewJohn » Tue Nov 05, 2019 12:43 am

The Python back-end has recently started having weird results when querying the design database (which is Mysql). The Python code will do a Mysql query and get different results from what I get with the same query entered directly into the Mysql command line tool. I am going to migrate the backend from Python2 to Python3. Python2 is hitting end-of-life very soon.

User avatar
mycelium
Posts: 27
Joined: Tue Aug 28, 2007 4:21 am
Location: Italy
Contact:

Re: Picture showing in Gallery but not Gallery 2

Post by mycelium » Tue Nov 19, 2019 1:30 pm

I have problems with gallery and upload from application too (mac os x 10.14.6).
I also think that it would be nice if images in gallery coould be 2x resolution, since hidpi screens are getting popular...

flembobs
Posts: 32
Joined: Tue Oct 09, 2012 3:00 pm

Re: Picture showing in Gallery but not Gallery 2

Post by flembobs » Fri Nov 22, 2019 12:33 pm

Another one of my designs is missing from the main gallery 'newest'.

It appears when you click 'view more'.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest